summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Remove-encoding-parameter-from-json.load-for-Python-.patch26
-rw-r--r--PKGBUILD13
3 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3cbd8852831..b3acffb0c7c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-geojson
pkgdesc = Python bindings and utilities for GeoJSON
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/frewsxcv/python-geojson
arch = any
license = BSD
makedepends = python-setuptools
depends = python
source = python-geojson-2.5.0.tar.gz::https://github.com/frewsxcv/python-geojson/archive/2.5.0.tar.gz
+ source = 0001-Remove-encoding-parameter-from-json.load-for-Python-.patch
sha1sums = e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd
+ sha1sums = fcb3e74597fe4858c95ab63c2d38b04f27e80516
pkgname = python-geojson
-
diff --git a/0001-Remove-encoding-parameter-from-json.load-for-Python-.patch b/0001-Remove-encoding-parameter-from-json.load-for-Python-.patch
new file mode 100644
index 000000000000..e211b3d402f7
--- /dev/null
+++ b/0001-Remove-encoding-parameter-from-json.load-for-Python-.patch
@@ -0,0 +1,26 @@
+From d88e32f1b05ad287a8d612e6f61ed7432fc72957 Mon Sep 17 00:00:00 2001
+From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
+Date: Mon, 10 Aug 2020 10:06:14 +0530
+Subject: [PATCH] Remove encoding parameter from json.load for Python 3.9
+ compatibility. (#151)
+
+---
+ tests/test_features.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_features.py b/tests/test_features.py
+index 529de70..e2b56e9 100644
+--- a/tests/test_features.py
++++ b/tests/test_features.py
+@@ -82,7 +82,7 @@ class FeaturesTest(unittest.TestCase):
+ ' "properties": {"summary": "The first feature",'
+ ' "link": "http://example.org/features/1",'
+ ' "title": "Feature 1"}}')
+- feature = geojson.loads(json, object_hook=factory, encoding="utf-8")
++ feature = geojson.loads(json, object_hook=factory)
+ self.assertEqual(repr(type(feature)),
+ "<class 'geojson.examples.SimpleWebFeature'>")
+ self.assertEqual(feature.id, '1')
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 30eab68f6991..a090ce1af8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,22 @@
# Contributor: Johannes Loethberg <johannes@kyriasis.com>
pkgname=python-geojson
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings and utilities for GeoJSON"
url="https://github.com/frewsxcv/python-geojson"
arch=('any')
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
-source=(python-geojson-$pkgver.tar.gz::https://github.com/frewsxcv/python-geojson/archive/$pkgver.tar.gz)
-sha1sums=('e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd')
+source=(python-geojson-$pkgver.tar.gz::https://github.com/frewsxcv/python-geojson/archive/$pkgver.tar.gz
+ 0001-Remove-encoding-parameter-from-json.load-for-Python-.patch)
+sha1sums=('e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd'
+ 'fcb3e74597fe4858c95ab63c2d38b04f27e80516')
+
+prepare() {
+ cd geojson-$pkgver
+ patch -p1 < "${srcdir}"/0001-Remove-encoding-parameter-from-json.load-for-Python-.patch
+}
build() {
cd geojson-$pkgver