summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9c1dd50a7e1..ea6cebad81c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
pkgbase = python-geopandas
pkgdesc = Geographic pandas extension
- pkgver = 0.2.1
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/geopandas/geopandas
arch = any
license = BSD
- checkdepends = python-nose
checkdepends = python-descartes
+ checkdepends = python-matplotlib
+ checkdepends = python-pytest
+ checkdepends = python-rtree
depends = python
+ depends = python-fiona
depends = python-numpy
depends = python-pandas
+ depends = python-pyproj
depends = python-shapely
- depends = python-fiona
depends = python-six
- depends = python-pyproj
+ optdepends = python-descartes
optdepends = python-geopy
optdepends = python-psycopg2
- optdepends = python-descartes
- optdepends = python-rtree
options = !emptydirs
- source = https://github.com/geopandas/geopandas/archive/v0.2.1.tar.gz
- sha256sums = 1e1845acbf6cf8dd2850aec9bfaa92892e462887903e3ea1abb8111e88a41206
+ source = https://github.com/geopandas/geopandas/archive/v0.3.0.tar.gz
+ sha256sums = ef49a5c8c2e6ff6ff43a494280d0749fdecdf65f4031624d1639fe238b551804
pkgname = python-geopandas
diff --git a/PKGBUILD b/PKGBUILD
index 7a1837fb2c65..2908a0131ecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-geopandas
_pkgname=geopandas
-pkgver=0.2.1
+pkgver=0.3.0
pkgrel=1
pkgdesc="Geographic pandas extension"
arch=('any')
url="https://github.com/geopandas/geopandas"
license=('BSD')
-checkdepends=('python-nose' 'python-descartes')
-depends=('python' 'python-numpy' 'python-pandas' 'python-shapely' 'python-fiona' 'python-six' 'python-pyproj')
-optdepends=('python-geopy' 'python-psycopg2' 'python-descartes' 'python-rtree')
+checkdepends=('python-descartes' 'python-matplotlib' 'python-pytest' 'python-rtree')
+depends=('python' 'python-fiona' 'python-numpy' 'python-pandas' 'python-pyproj' 'python-shapely' 'python-six')
+optdepends=('python-descartes' 'python-geopy' 'python-psycopg2')
options=(!emptydirs)
source=("https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz")
-sha256sums=('1e1845acbf6cf8dd2850aec9bfaa92892e462887903e3ea1abb8111e88a41206')
+sha256sums=('ef49a5c8c2e6ff6ff43a494280d0749fdecdf65f4031624d1639fe238b551804')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
}
-#check() {
-# cd "$srcdir/$_pkgname-$pkgver"
-# nosetests
-#}
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ pytest
+}
package() {
cd "$srcdir/$_pkgname-$pkgver"