summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19578ac9dc31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-getch
+ pkgdesc = Does single char input, like C getch/getche
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://pypi.org/project/getch/
+ arch = x86_64
+ license = custom
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/cc/a4/c696c05e0ff9d05b1886cb0210101083db7d330ff964a6d7cd98ad2b2064/getch-1.0.tar.gz
+ source = LICENSE
+ sha256sums = a6c22717c10051ce65b8fb7bddb171af705b1175e694a73be956990f6089d8b1
+ sha256sums = 248a70acfab06d527d96bb64a5bb24232c00b70874190f11ff7ab7eb2cc2db96
+
+pkgname = python-getch
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..71d15044000b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,2 @@
+Author: syscon
+License type: Public Domain (it really is just a small utility)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aeec0922a4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Klotz <vanziegelstein@gmail.com>
+
+pkgname=python-getch
+pkgver=1.0
+pkgrel=1
+pkgdesc="Does single char input, like C getch/getche"
+arch=('x86_64')
+url="https://pypi.org/project/getch/"
+license=('custom')
+makedepends=('python-setuptools')
+source=('https://files.pythonhosted.org/packages/cc/a4/c696c05e0ff9d05b1886cb0210101083db7d330ff964a6d7cd98ad2b2064/getch-1.0.tar.gz'
+LICENSE)
+sha256sums=('a6c22717c10051ce65b8fb7bddb171af705b1175e694a73be956990f6089d8b1'
+ '248a70acfab06d527d96bb64a5bb24232c00b70874190f11ff7ab7eb2cc2db96')
+
+
+build() {
+ cd "${pkgname#python-}-$pkgver"
+ python setup.py build
+}
+
+
+package() {
+ cd "${pkgname#python-}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}