summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfd43d8fad1c..4b7fd0069fd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-getdist-git
pkgdesc = MCMC sample analysis, kernel densities, plotting, and GUI
- pkgver = r112.de5e238
- pkgrel = 4
+ pkgver = r318.9949a14
+ pkgrel = 1
url = https://github.com/cmbant/getdist
arch = any
makedepends = git
@@ -10,7 +10,7 @@ pkgbase = python-getdist-git
depends = python-matplotlib
depends = python-six
depends = python-scipy
- depends = python-pyside
+ depends = pyside2
depends = python-pandas
provides = python-getdist
conflicts = python-getdist
@@ -18,4 +18,3 @@ pkgbase = python-getdist-git
md5sums = SKIP
pkgname = python-getdist-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dcccb2e36306
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.zst
+python-getdist/
diff --git a/PKGBUILD b/PKGBUILD
index a93812c4c269..0f8cf68b6f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
_pkgname=getdist
pkgname=python-$_pkgname-git
-pkgver=r112.de5e238
-pkgrel=4
+pkgver=r318.9949a14
+pkgrel=1
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
-arch=('any')
+arch=(any)
url="https://github.com/cmbant/getdist"
license=()
groups=()
-depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside' 'python-pandas')
-makedepends=('git' 'python-setuptools')
+depends=(python-numpy python-matplotlib python-six python-scipy pyside2 python-pandas)
+makedepends=(git python-setuptools)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -18,14 +18,19 @@ options=()
install=
source=("${pkgname%-git}::git+$url.git")
noextract=()
-md5sums=('SKIP')
+md5sums=(SKIP)
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/${pkgname%-git}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}