summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d6ff2876d76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-gitlab-registry-usage
+ pkgdesc = An extension for flask-restful to support the creation of APIs conforming to HAL.
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/sciapp/gitlab-registry-usage
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyopenssl
+ depends = python-requests
+ source = https://github.com/sciapp/gitlab-registry-usage/archive/v0.2.5.tar.gz
+ sha256sums = 3bd30eb2259097aeb430afb3ad4b1fe3f7ae19b9aa1ae779c984aa65817f5f9f
+
+pkgname = python-gitlab-registry-usage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2003141c0783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..738c0328c5cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ingo Heimbach <i.heimbach@fz-juelich.de>
+
+pkgname="python-gitlab-registry-usage"
+pkgver="0.2.5"
+pkgrel="1"
+pkgdesc="An extension for flask-restful to support the creation of APIs conforming to HAL."
+arch=("any")
+url="https://github.com/sciapp/gitlab-registry-usage"
+license=("MIT")
+depends=("python" "python-pyopenssl" "python-requests")
+makedepends=("python-setuptools")
+source=("https://github.com/sciapp/gitlab-registry-usage/archive/v${pkgver}.tar.gz")
+sha256sums=("3bd30eb2259097aeb430afb3ad4b1fe3f7ae19b9aa1ae779c984aa65817f5f9f")
+
+build() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}" || return
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname#*-}-${pkgver}" || return
+ python setup.py install --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}" \
+ --skip-build
+}