summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml3
-rw-r--r--PKGBUILD15
3 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e1c5efd8347..ce2c9822b6ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = python-glyphsets
pkgdesc = an API with data about glyph sets for many different scripts and languages
- pkgver = 0.5.1
+ pkgver = 0.6.19
pkgrel = 1
url = https://github.com/googlefonts/glyphsets
arch = any
license = Apache
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python
depends = python-defcon
depends = python-fonttools
depends = python-fs
depends = python-glyphslib
- source = https://files.pythonhosted.org/packages/source/g/glyphsets/glyphsets-0.5.1.tar.gz
- sha256sums = 93fec79840f27779ce4c696c716ed6f5ffe0174174fdf859ae1be182ea1df65d
+ source = https://files.pythonhosted.org/packages/source/g/glyphsets/glyphsets-0.6.19.tar.gz
+ sha256sums = bcef60ccc0973e592433d32d46196e9409d08bab9932d254d4da9c3fcc3ab42a
pkgname = python-glyphsets
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..96ddd2f4c732
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,3 @@
+[python-glyphsets]
+source = "pypi"
+pypi = "glyphsets"
diff --git a/PKGBUILD b/PKGBUILD
index 5d368e63b7cb..b6d939d34692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=glyphsets
pkgname=python-${_pyname,,}
-pkgver=0.5.1
+pkgver=0.6.19
pkgrel=1
pkgdesc='an API with data about glyph sets for many different scripts and languages'
arch=(any)
@@ -14,18 +14,11 @@ _pydeps=(defcon
glyphslib)
depends=(python
"${_pydeps[@]/#/python-}")
-makedepends=(python-{build,installer}
- python-setuptools
- python-wheel)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools-scm)
_archive="$_pyname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('93fec79840f27779ce4c696c716ed6f5ffe0174174fdf859ae1be182ea1df65d')
-prepare() {
- cd "$_archive"
- # Upstream requires outdated setuptools_scm, work around
- sed -i -e '/_scm/d' setup.py
- echo "version = '$pkgver'" > Lib/glyphsets/_version
-}
+sha256sums=('bcef60ccc0973e592433d32d46196e9409d08bab9932d254d4da9c3fcc3ab42a')
build() {
cd "$_archive"