summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e78c2dd3e35d..c28dfe108793 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-gogs-client
pkgdesc = Python client for Gogs server
pkgver = 1.0.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/unfoldingWord-dev/python-gogs-client
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index d0379004cc82..64b4e5167fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="python-gogs-client"
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Python client for Gogs server"
arch=("any")
url="https://github.com/unfoldingWord-dev/python-gogs-client"
@@ -23,9 +23,11 @@ package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root=${pkgdir}
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # see #18 in upstream
- # https://git.io/vhmg9
- rm "${pkgdir}/usr/lib/python3.6/site-packages/tests/__init__.py"
+ # see unfoldingWord-dev/python-gogs-client#18 in upstream
+ # also see SpotlightKid comment on 2019-03-10 20:21
+ # https://aur.archlinux.org/packages/python-gogs-client/
+ local pyver=$(python -c 'import sys; print("{0}.{1}".format(*sys.version_info))')
+ rm -f "${pkgdir}/usr/lib/python${pyver}/site-packages/tests/__init__.py"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: