summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
2 files changed, 11 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 044d0973aec1..bfc295ebadf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,23 @@
pkgbase = python-google-auth-httplib2-git
pkgdesc = Google Authentication Library: httplib2 transport
pkgver = r8.e7cd722
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2
arch = any
license = Apache
checkdepends = python-pytest-runner
- checkdepends = python2-pytest-runner
checkdepends = python-mock
- checkdepends = python2-mock
checkdepends = python-flask
- checkdepends = python2-flask
checkdepends = python-pytest-localserver
- checkdepends = python2-pytest-localserver
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-google-auth
- makedepends = python2-google-auth
- makedepends = python-httplib2
- makedepends = python2-httplib2
- makedepends = python-six
- makedepends = python2-six
makedepends = git
- source = git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git
- sha512sums = SKIP
-
-pkgname = python-google-auth-httplib2-git
depends = python-google-auth
depends = python-httplib2
depends = python-six
provides = python-google-auth-httplib2
conflicts = python-google-auth-httplib2
+ source = git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git
+ sha512sums = SKIP
-pkgname = python2-google-auth-httplib2-git
- depends = python2-google-auth
- depends = python2-httplib2
- depends = python2-six
- provides = python-google-auth-httplib2
- conflicts = python-google-auth-httplib2
+pkgname = python-google-auth-httplib2-git
diff --git a/PKGBUILD b/PKGBUILD
index 179803077372..8462c32c3f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Ainola
# Contributor: Felix Yan <felixonmars@archlinux.org> (Stable Package)
-pkgbase=python-google-auth-httplib2-git
-pkgname=(python-google-auth-httplib2-git python2-google-auth-httplib2-git)
+pkgname=python-google-auth-httplib2-git
pkgver=r8.e7cd722
-pkgrel=3
+pkgrel=4
pkgdesc="Google Authentication Library: httplib2 transport"
url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
license=('Apache')
arch=('any')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-google-auth' 'python2-google-auth'
- 'python-httplib2' 'python2-httplib2' 'python-six' 'python2-six' 'git')
-checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-mock' 'python2-mock'
- 'python-flask' 'python2-flask' 'python-pytest-localserver'
- 'python2-pytest-localserver')
+depends=('python-google-auth' 'python-httplib2' 'python-six')
+provides=('python-google-auth-httplib2')
+conflicts=('python-google-auth-httplib2')
+makedepends=('python-setuptools' 'git')
+checkdepends=('python-pytest-runner' 'python-mock' 'python-flask' 'python-pytest-localserver')
source=("git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git")
sha512sums=('SKIP')
@@ -22,43 +21,18 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cp -a google-auth-library-python-httplib2{,-py2}
-}
-
build() {
cd google-auth-library-python-httplib2
python setup.py build
-
- cd "$srcdir/google-auth-library-python-httplib2-py2"
- python2 setup.py build
}
check() {
cd google-auth-library-python-httplib2
python setup.py pytest
-
- cd ../google-auth-library-python-httplib2-py2
- python2 setup.py pytest
}
package_python-google-auth-httplib2-git() {
- depends=('python-google-auth' 'python-httplib2' 'python-six')
- provides=('python-google-auth-httplib2')
- conflicts=('python-google-auth-httplib2')
-
cd google-auth-library-python-httplib2
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_python2-google-auth-httplib2-git() {
- depends=('python2-google-auth' 'python2-httplib2' 'python2-six')
- provides=('python-google-auth-httplib2')
- conflicts=('python-google-auth-httplib2')
-
- cd google-auth-library-python-httplib2-py2
- python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-