summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57fca8804b48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-google-auth-httplib2-git
+ pkgdesc = An httplib2 transport for google-auth
+ pkgver = r8.e7cd722
+ pkgrel = 1
+ url = https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-google-auth
+ depends = python-httplib2
+ depends = python-six
+ provides = python-google-auth-httplib2
+ source = git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git
+ sha256sums = SKIP
+
+pkgname = python-google-auth-httplib2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378bc2496b8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ainola
+
+pkgname=python-google-auth-httplib2-git
+pkgver=r8.e7cd722
+pkgrel=1
+pkgdesc="An httplib2 transport for google-auth"
+arch=('any')
+url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+license=('Apache')
+makedepends=('python-setuptools')
+depends=('python' 'python-google-auth' 'python-httplib2' 'python-six')
+provides=('python-google-auth-httplib2')
+source=("git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/google-auth-library-python-httplib2"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/google-auth-library-python-httplib2"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/google-auth-library-python-httplib2"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}