summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md22
-rw-r--r--PKGBUILD12
3 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f7f1a015327..afe4520a0755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.20.1
- pkgrel = 1
+ pkgver = 3.21.0
+ pkgrel = 2
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
arch = any
@@ -27,7 +27,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-pandas: pandas support
optdepends = python-snappy: fastparquet support
optdepends = python-tqdm: tqdm support
- source = python-google-cloud-bigquery-3.20.1.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.20.1.tar.gz
- b2sums = 6a693d0f348f90542c1ac37938ab49065ef95402e0ec1f972437e20dc5607f88b813b4af4bab33f7bb6ca970a1bd17d16c318630e2b21afdd8933c63b4857626
+ source = python-google-cloud-bigquery-3.21.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.21.0.tar.gz
+ b2sums = 9b43d45e61eea98f250265b2ea3f59fe7e042bee4a22be1977ce997739d6020d35c93b9c4de4d7ecfa060a7536428b6596a3e0cedf0f3bf0898535fd847f292a
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 95af2d213693..0fc77f7c5c79 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,28 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.21.0](https://github.com/googleapis/python-bigquery/compare/v3.20.1...v3.21.0) (2024-04-18)
+
+
+### Features
+
+* Add compression option ZSTD. ([#1890](https://github.com/googleapis/python-bigquery/issues/1890)) ([5ed9cce](https://github.com/googleapis/python-bigquery/commit/5ed9ccee204b7cf8e96cb0e050f6830c05f3b4fd))
+* Adds billing to opentel ([#1889](https://github.com/googleapis/python-bigquery/issues/1889)) ([38697fb](https://github.com/googleapis/python-bigquery/commit/38697fb942516fc2f6f5e21e19a11811fbaeb1f4))
+* Support RANGE in queries Part 1: JSON ([#1884](https://github.com/googleapis/python-bigquery/issues/1884)) ([3634405](https://github.com/googleapis/python-bigquery/commit/3634405fa1b40ae5f69b06d7c7f8de4e3d246d92))
+
+
+### Bug Fixes
+
+* Add types to DatasetReference constructor ([#1601](https://github.com/googleapis/python-bigquery/issues/1601)) ([bf8861c](https://github.com/googleapis/python-bigquery/commit/bf8861c3473a1af978db7a06463ddc0bad86f326))
+* Creates linting-typing.cfg in presubmit ([#1881](https://github.com/googleapis/python-bigquery/issues/1881)) ([c852c15](https://github.com/googleapis/python-bigquery/commit/c852c153c55025ba1187d61e313ead2308616c55))
+* Remove duplicate key time_partitioning from Table._PROPERTY_TO_A… ([#1898](https://github.com/googleapis/python-bigquery/issues/1898)) ([82ae908](https://github.com/googleapis/python-bigquery/commit/82ae908fbf3b2361343fff1859d3533383dc50ec))
+* Retry query jobs that fail even with ambiguous `jobs.getQueryResults` REST errors ([#1903](https://github.com/googleapis/python-bigquery/issues/1903), [#1900](https://github.com/googleapis/python-bigquery/issues/1900)) ([1367b58](https://github.com/googleapis/python-bigquery/commit/1367b584b68d917ec325ce4383a0e9a36205b894))
+
+
+### Performance Improvements
+
+* Avoid unnecessary API call in `QueryJob.result()` when job is already finished ([#1900](https://github.com/googleapis/python-bigquery/issues/1900)) ([1367b58](https://github.com/googleapis/python-bigquery/commit/1367b584b68d917ec325ce4383a0e9a36205b894))
+
## [3.20.1](https://github.com/googleapis/python-bigquery/compare/v3.20.0...v3.20.1) (2024-04-01)
diff --git a/PKGBUILD b/PKGBUILD
index e9abadf7e27a..63044470c405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pyname=google-cloud-bigquery
pkgname=python-google-cloud-bigquery
-pkgver=3.20.1
-pkgrel=1
+pkgver=3.21.0
+pkgrel=2
pkgdesc='Google BigQuery API client library'
arch=(any)
url=https://github.com/googleapis/python-bigquery
@@ -38,7 +38,7 @@ optdepends=(
changelog=CHANGELOG.md
# source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
-b2sums=(6a693d0f348f90542c1ac37938ab49065ef95402e0ec1f972437e20dc5607f88b813b4af4bab33f7bb6ca970a1bd17d16c318630e2b21afdd8933c63b4857626)
+b2sums=(9b43d45e61eea98f250265b2ea3f59fe7e042bee4a22be1977ce997739d6020d35c93b9c4de4d7ecfa060a7536428b6596a3e0cedf0f3bf0898535fd847f292a)
build() {
cd ${_pyname}-${pkgver}
@@ -55,9 +55,9 @@ package() {
python -m installer \
--destdir="${pkgdir}" \
dist/*.whl
- install -Dm644 README.rst -t "${pkgdir}"/usr/share/doc/${pkgname}/
- # install -Dm644 docs/_build/google-cloud-bigquery.1 -t "${pkgdir}"/usr/share/man/man1/
- install -d "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -Dm644 README.rst -t "${pkgdir}"/usr/share/doc/${pkgname}
+ # install -Dm644 docs/_build/google-cloud-bigquery.1 -t "${pkgdir}"/usr/share/man/man1
+ install -d "${pkgdir}"/usr/share/licenses/${pkgname}
ln -s \
${_site}/google_cloud_bigquery-${pkgver}.dist-info/LICENSE \
"${pkgdir}"/usr/share/licenses/${pkgname}/