summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe9cdd499496..f7cf40b29092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,33 +8,36 @@ license=('custom')
source=("$pkgname-$pkgver::https://github.com/gradio-app/gradio/archive/refs/tags/v$pkgver.tar.gz")
sha512sums=('ca265f7f3d83a742edc9a2728435fcfc382d54a1507a6c9ecdec30833db74c7fe44097df8aa703c7045ad1057f60dcd451ff2674d7bcf43e8c9772bd47c526c6')
depends=(
+ 'python-aiofiles'
'python-aiohttp'
- 'python-h11'
+ 'python-altair'
'python-fastapi'
'python-ffmpy'
+ 'python-gradio-client'
+ 'python-httpx'
+ 'python-huggingface-hub'
+ 'python-jinja'
'python-markdown-it-py'
+ 'python-pygments'
+ 'python-mdit_py_plugins'
+ 'python-typing_extensions'
+ 'python-markupsafe'
'python-matplotlib'
'python-numpy'
'python-orjson'
'python-pandas'
- 'python-paramiko'
'python-pillow'
- 'python-pycryptodome'
+ 'python-pydantic'
'python-python-multipart'
'python-pydub'
'python-yaml'
'python-requests'
+ 'python-semantic-version'
+ 'python-typing_extensions'
'uvicorn'
- 'python-jinja'
- 'python-fsspec'
- 'python-httpx'
- 'python-pydantic'
'python-websockets'
+
'python-linkify-it-py'
- 'python-mdit_py_plugins'
- 'python-typing_extensions'
- 'python-markupsafe'
- 'python-altair'
)
makedepends=(python-build python-installer python-wheel python-hatchling python-hatch-requirements-txt python-hatch-fancy-pypi-readme pnpm)