summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3100de00c822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-grandalf
+ pkgdesc = Python package made for experimentations with graphs drawing algorithms..
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/bdcht/grandalf
+ arch = any
+ license = custom:MIT
+ depends = python-ply
+ source = python-grandalf-0.7.tar.gz::https://github.com/bdcht/grandalf/archive/v0.7.tar.gz
+ sha256sums = b3112299fe0a9123c088a16bf2f1b541d0d91199b77170a9739b569bd16a828e
+
+pkgname = python-grandalf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c29cc67fc31b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=python-grandalf
+pkgver=0.7
+pkgrel=1
+pkgdesc="Python package made for experimentations with graphs drawing algorithms.."
+arch=('any')
+license=('custom:MIT')
+url="https://github.com/bdcht/grandalf"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('b3112299fe0a9123c088a16bf2f1b541d0d91199b77170a9739b569bd16a828e')
+depends=('python-ply')
+
+build() {
+ cd ${pkgname#python-}-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname#python-}-$pkgver
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}