summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 4 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad4cff707465..577d7214c59d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = python-habitipy
pkgdesc = A set of scripts to interact with Habitica
pkgver = 0.3.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/ASMfreaK/habitipy
arch = any
license = MIT
makedepends = python-pbr>=1.9
- makedepends = python2-pbr>=1.9
source = https://files.pythonhosted.org/packages/source/h/habitipy/habitipy-0.3.0.tar.gz
source = LICENSE
sha256sums = 6b2d01eab4da0b2b78280ce0f670c5f7b4c249e1b0794e544fa1f2f4d07ec2a3
@@ -16,8 +15,3 @@ pkgname = python-habitipy
depends = python-pbr
depends = python-requests
depends = python-plumbum
-
-pkgname = python2-habitipy
- depends = python2-pbr
- depends = python2-requests
- depends = python2-plumbum
diff --git a/PKGBUILD b/PKGBUILD
index 940f1ab4803d..f250351e6f2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_name="habitipy"
_module="$_name"
-pkgname=("python-$_module" "python2-$_module")
+pkgname=("python-$_module")
pkgdesc="A set of scripts to interact with Habitica"
pkgver="0.3.0"
-pkgrel=4
+pkgrel=5
url="https://github.com/ASMfreaK/habitipy"
license=('MIT')
arch=('any')
-makedepends=("python-pbr>=1.9" "python2-pbr>=1.9")
+makedepends=("python-pbr>=1.9")
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
"LICENSE")
sha256sums=('6b2d01eab4da0b2b78280ce0f670c5f7b4c249e1b0794e544fa1f2f4d07ec2a3'
@@ -30,12 +30,3 @@ package_python-habitipy(){
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
}
-
-package_python2-habitipy(){
- depends=("python2-pbr"
- "python2-requests"
- "python2-plumbum")
- cd "$_name-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
-}