summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7d648325b6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 7 22:58:15 UTC 2015
+pkgbase = python-hackchat
+ pkgdesc = A library to work with hack.chat
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/gkbrk/hackchat/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-websocket-client
+ options = !emptydirs
+ source = git+https://github.com/gkbrk/hackchat.git
+ md5sums = SKIP
+
+pkgname = python-hackchat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45b5a81985a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Holden Salomon <holden@cryptolab.net>
+pkgname=python-hackchat
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="A library to work with hack.chat"
+arch=(any)
+url="https://github.com/gkbrk/hackchat/"
+license=(MIT)
+depends=(python python-websocket-client)
+makedepends=(git python-setuptools)
+options=(!emptydirs)
+source=("git+https://github.com/gkbrk/hackchat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/hackchat"
+ python setup.py --version
+}
+
+package() {
+ cd "$srcdir/hackchat"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+