summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c71819bf4e38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-hasel
+ pkgdesc = python+numpy RGB to HSL (and vice versa) converter
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/sumartoyo/hasel
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ provides = python-hasel
+ conflicts = python-hasel
+ source = https://pypi.python.org/packages/1b/4b/40372d92b6371efda7e23e24fb47fa97a6c661d1f98717734daa5fefed55/hasel-1.0.1.tar.gz
+ md5sums = c9cfa80468f3f0f70e5a55f461d04949
+
+pkgname = python-hasel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28c728a7e941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Marcel Robitaille mail@marcelrobitaille.me
+_python=python
+_distname=hasel
+pkgname=$_python-$_distname
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="python+numpy RGB to HSL (and vice versa) converter"
+arch=(any)
+url="https://github.com/sumartoyo/hasel"
+license=('MIT')
+depends=('python' 'python-setuptools')
+provides=('python-hasel')
+conflicts=('python-hasel')
+source=("https://pypi.python.org/packages/1b/4b/40372d92b6371efda7e23e24fb47fa97a6c661d1f98717734daa5fefed55/$_distname-$pkgver.tar.gz")
+md5sums=('c9cfa80468f3f0f70e5a55f461d04949')
+
+package() {
+ cd "$srcdir/$_distname-$pkgver"
+ $_python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || exit 1
+}
+