summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec9635f654ff..490872b2bc1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.16.5
+ pkgver = 1.16.6
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -14,14 +14,14 @@ pkgbase = python-healpy
makedepends = python-build
makedepends = python-installer
depends = python>=3.8
- depends = python-numpy>=1.13
+ depends = python-numpy>=1.19
depends = python-scipy
depends = python-matplotlib
depends = python-astropy
depends = cfitsio>=4.1.0
depends = healpix>=3.82
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.5.tar.gz
- md5sums = 8c6d4b9c9fd87489827e1c08b918d383
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.6.tar.gz
+ md5sums = 3ce7788da61cc6e8ad38c9cd0267ed04
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index b85a4ce5b766..5bb790f1f1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.5
+pkgver=1.16.6
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.8' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.82')
+depends=('python>=3.8' 'python-numpy>=1.19' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.82')
makedepends=('python-setuptools-scm>=6.2'
'cython'
'python-wheel'
@@ -18,7 +18,7 @@ optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython'
'python-pytest-doctestplus') # requests -> pooch -> scipy
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('8c6d4b9c9fd87489827e1c08b918d383')
+md5sums=('3ce7788da61cc6e8ad38c9cd0267ed04')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -27,7 +27,7 @@ get_pyver() {
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- sed -i -e "/oldest-supported-numpy/d" -e "/\"wheel\"/s/,/\]/" pyproject.toml
+ sed -i -e "/pykg/d" -e "/\"numpy>=1.25\"/s/,/\]/" pyproject.toml
}
build() {