summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07b3af9994ad..490872b2bc1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.16.1
+ pkgver = 1.16.6
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -8,21 +8,20 @@ pkgbase = python-healpy
license = GPL
checkdepends = python-pytest-cython
checkdepends = python-pytest-doctestplus
- checkdepends = python-requests
- makedepends = python-setuptools
+ makedepends = python-setuptools-scm>=6.2
makedepends = cython
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- depends = python>=3.7
- depends = python-numpy>=1.13
+ depends = python>=3.8
+ depends = python-numpy>=1.19
depends = python-scipy
depends = python-matplotlib
depends = python-astropy
depends = cfitsio>=4.1.0
- depends = healpix>=3.80
+ depends = healpix>=3.82
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.1.tar.gz
- md5sums = e5993b888192847eee9b622bb3b06f51
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.6.tar.gz
+ md5sums = 3ce7788da61cc6e8ad38c9cd0267ed04
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index 387e12bdd7c8..5bb790f1f1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,32 @@
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.1
+pkgver=1.16.6
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.80')
-makedepends=('python-setuptools'
+depends=('python>=3.8' 'python-numpy>=1.19' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.82')
+makedepends=('python-setuptools-scm>=6.2'
'cython'
'python-wheel'
'python-build'
'python-installer')
optdepends=('python-healpy-doc: Documentation for healpy')
-checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
+checkdepends=('python-pytest-cython'
+ 'python-pytest-doctestplus') # requests -> pooch -> scipy
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('e5993b888192847eee9b622bb3b06f51')
+md5sums=('3ce7788da61cc6e8ad38c9cd0267ed04')
get_pyver() {
- python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- sed -i -e "/oldest-supported-numpy/d" -e "/\"wheel\"/s/,/\]/" pyproject.toml
+ sed -i -e "/pykg/d" -e "/\"numpy>=1.25\"/s/,/\]/" pyproject.toml
}
build() {
@@ -39,12 +40,12 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
# skip tests that cost lots of time
- pytest "build/lib.linux-${CARCH}-$(get_pyver)" \
- --deselect=build/lib.linux-x86_64-3.10/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed"
+ pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
+ --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package() {
- cd ${srcdir}/healpy-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python -m installer --destdir="${pkgdir}" dist/*.whl