summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a53e0d3c81a1..5f533926de1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.13.0
+ pkgver = 1.14.0
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
arch = x86_64
license = GPL
checkdepends = python-pytest-cython
+ checkdepends = python-pytest-doctestplus
+ checkdepends = python-pillow
+ checkdepends = python-requests
makedepends = cython>=0.16
makedepends = python-pytest-runner
- makedepends = python-six
depends = python>=3.4
depends = python-numpy>=1.13
depends = python-matplotlib
depends = python-astropy
depends = cfitsio
depends = healpix>=3.60
+ depends = python-six
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.13.0.tar.gz
- md5sums = f7b055f9ce11faa827890bbcfb0663ba
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.14.0.tar.gz
+ md5sums = 2e56fdad5fa3780f7381449a7b2672fb
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index 71a21f45095b..ac16b7ad666f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.13.0
+pkgver=1.14.0
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.4' 'python-numpy>=1.13' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60')
-makedepends=('cython>=0.16' 'python-pytest-runner' 'python-six')
+depends=('python>=3.4' 'python-numpy>=1.13' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60' 'python-six')
+makedepends=('cython>=0.16' 'python-pytest-runner')
optdepends=('python-healpy-doc: Documentation for healpy')
-checkdepends=('python-pytest-cython')
+checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-pillow' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('f7b055f9ce11faa827890bbcfb0663ba')
+md5sums=('2e56fdad5fa3780f7381449a7b2672fb')
prepare() {
- export _pyver=$(python -V | cut -c 8-10)
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
@@ -27,7 +27,7 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
- PYTHONPATH="./build/lib.linux-${CARCH}-${_pyver}" pytest
+ pytest
}
package() {