summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05ffde734584..07b3af9994ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.16.0
+ pkgver = 1.16.1
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -19,10 +19,10 @@ pkgbase = python-healpy
depends = python-scipy
depends = python-matplotlib
depends = python-astropy
- depends = cfitsio
+ depends = cfitsio>=4.1.0
depends = healpix>=3.80
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.0.tar.gz
- md5sums = 2a386129ccad6469d5a3398d0b920923
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.1.tar.gz
+ md5sums = e5993b888192847eee9b622bb3b06f51
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index 9110dcb9c378..387e12bdd7c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.0
+pkgver=1.16.1
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.80')
+depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.80')
makedepends=('python-setuptools'
'cython'
'python-wheel'
@@ -16,7 +17,7 @@ makedepends=('python-setuptools'
optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('2a386129ccad6469d5a3398d0b920923')
+md5sums=('e5993b888192847eee9b622bb3b06f51')
get_pyver() {
python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'