summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD12
-rw-r--r--fix_doc_warning.patch (renamed from fix_underline_warning.patch)17
4 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df69664fdd5e..125ac78e30ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Mar 23 05:31:43 UTC 2019
pkgbase = python-healpy-doc
pkgdesc = Documentation for Python iminuit module
- pkgver = 1.12.9
- pkgrel = 2
+ pkgver = 1.12.10
+ pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
arch = x86_64
license = GPL
- makedepends = python-healpy=1.12.9
+ makedepends = python-healpy=1.12.10
makedepends = python-numpydoc
- source = https://github.com/healpy/healpy/archive/1.12.9.tar.gz
- source = fix_underline_warning.patch
- md5sums = 2966c57f48c637611fe407fafa66f3b8
- md5sums = d1fd09c9686b5eebdfbf06cd902e8575
+ source = https://github.com/healpy/healpy/archive/1.12.10.tar.gz
+ source = fix_doc_warning.patch
+ md5sums = ce75bb08a66a215c22af50a71bab006f
+ md5sums = 685840f1c3333c81d00b9eea58aafc8e
pkgname = python-healpy-doc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d6e3b36c63a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 6356126311d2..97ff2544244f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
_pyname=healpy
pkgname=python-${_pyname}-doc
-pkgver=1.12.9
-pkgrel=2
+pkgver=1.12.10
+pkgrel=1
pkgdesc="Documentation for Python iminuit module"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
makedepends=("python-${_pyname}=${pkgver}" 'python-numpydoc')
source=("https://github.com/healpy/healpy/archive/${pkgver}.tar.gz"
- 'fix_underline_warning.patch')
-md5sums=('2966c57f48c637611fe407fafa66f3b8'
- 'd1fd09c9686b5eebdfbf06cd902e8575')
+ 'fix_doc_warning.patch')
+md5sums=('ce75bb08a66a215c22af50a71bab006f'
+ '685840f1c3333c81d00b9eea58aafc8e')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- patch -Np1 -i "${srcdir}/fix_underline_warning.patch"
+ patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
}
build() {
diff --git a/fix_underline_warning.patch b/fix_doc_warning.patch
index d3b338c5d880..19390be07c44 100644
--- a/fix_underline_warning.patch
+++ b/fix_doc_warning.patch
@@ -1,5 +1,6 @@
---- a/doc/healpy_zoomtool.rst 2019-03-22 05:51:07.000000000 +0800
-+++ b/doc/healpy_zoomtool.rst 2019-03-23 11:08:47.898324511 +0800
+diff -ura a/doc/healpy_zoomtool.rst b/doc/healpy_zoomtool.rst
+--- a/doc/healpy_zoomtool.rst 2019-09-10 13:17:36.000000000 +0800
++++ b/doc/healpy_zoomtool.rst 2019-09-10 14:17:14.230737604 +0800
@@ -4,7 +4,7 @@
@@ -10,8 +11,8 @@
Interactive map visualization
-----------------------------
diff -ura a/INSTALL.rst b/INSTALL.rst
---- a/INSTALL.rst 2019-03-22 05:51:07.000000000 +0800
-+++ b/INSTALL.rst 2019-03-23 11:09:21.075138156 +0800
+--- a/INSTALL.rst 2019-09-10 13:17:36.000000000 +0800
++++ b/INSTALL.rst 2019-09-10 14:16:27.437402127 +0800
@@ -10,7 +10,7 @@
Only Linux and MAC OS X are supported, not Windows.
@@ -30,3 +31,11 @@ diff -ura a/INSTALL.rst b/INSTALL.rst
It is possible to build the latest ``healpy`` with `pip <http://www.pip-installer.org>`_ ::
+@@ -73,6 +73,7 @@
+ If everything goes fine, you can test it::
+
+ python
++
+ >>> import matplotlib.pyplot as plt
+ >>> import numpy as np
+ >>> import healpy as hp