summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--mse.patch25
3 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61ab681e890c..67d79b474c29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-hep_ml
pkgdesc = Specific machine learning tools for purposes of high energy physics
- pkgver = 0.7.0
+ pkgver = 0.7.2
pkgrel = 1
url = https://arogozhnikov.github.io/hep_ml/
arch = any
@@ -13,9 +13,7 @@ pkgbase = python-hep_ml
depends = python-six
depends = python-pandas
depends = python-theano
- source = python-hep_ml-0.7.0.tar.gz::https://github.com/arogozhnikov/hep_ml/archive/v0.7.0.tar.gz
- source = mse.patch
- sha256sums = 24bd5c61d0f3dc0660c158fcc2313fba3be04de9bf1162bf53728ff381154f0c
- sha256sums = 86d42b9026fce2d623da01c6ceabb4bc85249dfa271d3a7c60fc8645623045d0
+ source = python-hep_ml-0.7.2.tar.gz::https://github.com/arogozhnikov/hep_ml/archive/v0.7.2.tar.gz
+ b2sums = a9da308da46ecc70aa1829e01b1e1692f5231c498ee6d6687132fbd03b3b6b1e028a4e1ae53a53e8f7e024784fcb47278ce17d8bbd310193b4be57955babd123
pkgname = python-hep_ml
diff --git a/PKGBUILD b/PKGBUILD
index bef7dbe6284d..de77ce5e9105 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=hep_ml
pkgname="python-${_pkgname}"
-pkgver=0.7.0
+pkgver=0.7.2
pkgrel=1
pkgdesc="Specific machine learning tools for purposes of high energy physics"
arch=('any')
@@ -11,15 +11,8 @@ license=('Apache')
makedepends=('python-setuptools')
depends=('python-numpy' 'python-scikit-learn' 'python-scipy' 'python-six' 'python-pandas' 'python-theano')
checkdepends=('python-nose')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/arogozhnikov/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'mse.patch')
-sha256sums=('24bd5c61d0f3dc0660c158fcc2313fba3be04de9bf1162bf53728ff381154f0c'
- '86d42b9026fce2d623da01c6ceabb4bc85249dfa271d3a7c60fc8645623045d0')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/mse.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/arogozhnikov/${_pkgname}/archive/v${pkgver}.tar.gz")
+b2sums=('a9da308da46ecc70aa1829e01b1e1692f5231c498ee6d6687132fbd03b3b6b1e028a4e1ae53a53e8f7e024784fcb47278ce17d8bbd310193b4be57955babd123')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/mse.patch b/mse.patch
deleted file mode 100644
index 5c892e78c7f1..000000000000
--- a/mse.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d7d5d75c17637ac68bc7b9ec38e39fbe915152af Mon Sep 17 00:00:00 2001
-From: Jonas Eschle <jonas.eschle@cern.ch>
-Date: Thu, 17 Feb 2022 13:47:49 +0100
-Subject: [PATCH] Upgrade sklearn criterion mse to squared_error
-
-mse is deprecated and will be removed: https://scikit-learn.org/stable/modules/generated/sklearn.tree.DecisionTreeRegressor.html
-
-`squared_error` is equivalent.
----
- hep_ml/gradientboosting.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/hep_ml/gradientboosting.py b/hep_ml/gradientboosting.py
-index ebdae19..a36f8ed 100644
---- a/hep_ml/gradientboosting.py
-+++ b/hep_ml/gradientboosting.py
-@@ -118,7 +118,7 @@ def fit(self, X, y, sample_weight=None):
- for stage in range(self.n_estimators):
- # tree creation
- tree = SklearnClusteringTree(
-- criterion='mse',
-+ criterion='squared_error',
- splitter=self.splitter,
- max_depth=self.max_depth,
- min_samples_split=self.min_samples_split,