summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 31 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4004bcf9f1de..c42705ea6b30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = python-holoviews
- pkgdesc = Stop plotting your data - annotate your data and let it visualize itself.
- pkgver = 1.13.4
+ pkgdesc = With Holoviews, your data visualizes itself
+ pkgver = 1.14.6
pkgrel = 1
- url = http://holoviews.org
+ url = https://holoviews.org
arch = any
- license = BSD
- makedepends = python-pyct
- depends = python-numpy
- depends = python-param
+ license = custom:BSD-3-clause
+ makedepends = python-setuptools
depends = python-pandas
depends = python-panel
- depends = python-pyviz_comms
- options = !emptydirs
- source = https://files.pythonhosted.org/packages/26/ee/874b92109ecb76d0b5a71edf50971c94db0c6717867d70e8c2e81a824872/holoviews-1.13.4.tar.gz
- sha256sums = 34dc09dfb557f79515a011a72b343daf31b5e5d67403a008dded59bab658267c
+ depends = python-colorcet
+ source = holoviews-1.14.6::https://github.com/holoviz/holoviews/archive/v1.14.6.tar.gz
+ sha512sums = 309c808e9c48cb763d882515b7bb85890abb86009451dc4f54bee6f8190cf180840d838bf824839aabea4cb425e133bab53ef9de825d01bf741f67e1c1e1d120
pkgname = python-holoviews
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 63780cc2d540..7ef7bb6df1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
-# Maintainer: Markus Kaiser <markus dot kaiser at in dot tum dot de>
-_pkgname=holoviews
-pkgname=python-$_pkgname
-pkgver=1.13.4
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Markus Kaiser <markus dot kaiser at in dot tum dot de>
+_base=holoviews
+pkgname=python-${_base}
+pkgver=1.14.6
pkgrel=1
-pkgdesc="Stop plotting your data - annotate your data and let it visualize itself."
-arch=("any")
-url="http://holoviews.org"
-license=('BSD')
-depends=('python-numpy' 'python-param' 'python-pandas' 'python-panel' 'python-pyviz_comms')
-makedepends=('python-pyct')
-options=(!emptydirs)
-source=('https://files.pythonhosted.org/packages/26/ee/874b92109ecb76d0b5a71edf50971c94db0c6717867d70e8c2e81a824872/holoviews-1.13.4.tar.gz')
-sha256sums=('34dc09dfb557f79515a011a72b343daf31b5e5d67403a008dded59bab658267c')
+pkgdesc="With Holoviews, your data visualizes itself"
+arch=('any')
+url="https://${_base}.org"
+license=('custom:BSD-3-clause')
+depends=(python-pandas python-panel python-colorcet)
+makedepends=(python-setuptools)
+source=(${_base}-${pkgver}::https://github.com/holoviz/${_base}/archive/v${pkgver}.tar.gz)
+sha512sums=('309c808e9c48cb763d882515b7bb85890abb86009451dc4f54bee6f8190cf180840d838bf824839aabea4cb425e133bab53ef9de825d01bf741f67e1c1e1d120')
-package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd "${_base}-${pkgver}"
+ python setup.py build
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "${_base}-${pkgver}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}