summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 564a95bb5c01..ef562c56c927 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = python-holoviews
pkgdesc = With Holoviews, your data visualizes itself
pkgver = 1.15.1
- pkgrel = 1
+ pkgrel = 2
url = https://holoviews.org
arch = any
license = custom:BSD-3-clause
+ makedepends = python-build
+ makedepends = python-installer
depends = python-pandas
depends = python-panel
depends = python-colorcet
diff --git a/PKGBUILD b/PKGBUILD
index a2f224c1900e..ddab1699e89c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,30 @@
_base=holoviews
pkgname=python-${_base}
pkgver=1.15.1
-pkgrel=1
+pkgrel=2
pkgdesc="With Holoviews, your data visualizes itself"
arch=(any)
url="https://${_base}.org"
license=('custom:BSD-3-clause')
depends=(python-pandas python-panel python-colorcet)
+makedepends=(python-build python-installer)
optdepends=('jupyter-nbconvert: for use holoviews command')
source=(${_base}-${pkgver}.tar.gz::https://github.com/holoviz/${_base}/archive/v${pkgver}.tar.gz)
sha512sums=('93d0703477e2b7e39adbfc28a8c6c360e4b7fe2f6ae87be11225cd3e47f973b9503c17320c6f7cc59c3ff25392b9fa58b684cb0d0c6d1b0e2071291076e926af')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}