summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD52
2 files changed, 33 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 515efd63024f..a30ba33ed26a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-horovod
pkgdesc = Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet
- pkgver = 0.19.5
- pkgrel = 1
+ pkgver = 0.20.3
+ pkgrel = 2
url = https://github.com/horovod/horovod
arch = x86_64
license = Apache
@@ -25,10 +25,10 @@ pkgbase = python-horovod
depends = python-scipy
depends = python-six
depends = python-tqdm
- optdepends = mxnet-cuda
- optdepends = python-pytorch-cuda
- optdepends = python-tensorflow-cuda
- source = horovod-0.19.5::git+https://github.com/horovod/horovod.git#tag=v0.19.5
+ optdepends = mxnet-cuda: mxnet framework
+ optdepends = python-pytorch-cuda: pytorch framework
+ optdepends = python-tensorflow-cuda: tensorflow framework
+ source = horovod-0.20.3::git+https://github.com/horovod/horovod.git#tag=v0.20.3
sha512sums = SKIP
pkgname = python-horovod
diff --git a/PKGBUILD b/PKGBUILD
index 1e0367589b97..380691f5884e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,40 @@
_pkgname=horovod
pkgname=python-horovod
-pkgver=0.19.5
-pkgrel=1
+pkgver=0.20.3
+pkgrel=2
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
url='https://github.com/horovod/horovod'
license=('Apache')
depends=(
- 'cuda'
- 'cudnn'
- 'nccl'
- 'openmpi'
- 'python-cloudpickle'
- 'python-h5py'
- 'python-mock'
- 'python-mpi4py'
- 'python-psutil'
- 'python-pycparser'
- 'python-pyaml'
- 'python-scipy'
- 'python-six'
- 'python-tqdm'
+ cuda
+ cudnn
+ nccl
+ openmpi
+ python-cloudpickle
+ python-h5py
+ python-mock
+ python-mpi4py
+ python-psutil
+ python-pycparser
+ python-pyaml
+ python-scipy
+ python-six
+ python-tqdm
)
makedepends=(
- 'cmake'
- 'git'
- 'mxnet-cuda'
- 'python-pytorch-cuda'
- 'python-setuptools'
- 'python-tensorflow-cuda'
+ cmake
+ git
+ mxnet-cuda
+ python-pytorch-cuda
+ python-setuptools
+ python-tensorflow-cuda
)
optdepends=(
- 'mxnet-cuda'
- 'python-pytorch-cuda'
- 'python-tensorflow-cuda'
+ 'mxnet-cuda: mxnet framework'
+ 'python-pytorch-cuda: pytorch framework'
+ 'python-tensorflow-cuda: tensorflow framework'
)
source=("${_pkgname}-${pkgver}::git+https://github.com/horovod/horovod.git#tag=v${pkgver}")
sha512sums=('SKIP')
@@ -58,8 +58,10 @@ prepare() {
export HOROVOD_WITH_MXNET=1
export HOROVOD_WITH_PYTORCH=1
export HOROVOD_WITH_TENSORFLOW=1
+ export HOROVOD_BUILD_CUDA_CC_LIST="52,53,60,61,62,70,72,75,80"
export CC=/opt/cuda/bin/gcc
export CXX=/opt/cuda/bin/g++
+ export MAKEFLAGS="-j1"
}
build() {