summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56ca58d83474
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-html-purifier-git
+ pkgdesc = A Python module to purify HTML.
+ pkgver = 0.r26.00f38b6
+ pkgrel = 1
+ url = https://github.com/PixxxeL/python-html-purifier.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ provides = python-html-purifier
+ source = git+https://github.com/PixxxeL/python-html-purifier.git
+ md5sums = SKIP
+ sha1sums = SKIP
+ sha256sums = SKIP
+
+pkgname = python-html-purifier-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76b1a0a2c21b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Manuel Palenzuela <sadshinobi@protonmail.com>
+
+author=PixxxeL
+pkgname=python-html-purifier-git
+_gitname=python-html-purifier
+pkgver=0.r26.00f38b6
+pkgrel=1
+pkgdesc='A Python module to purify HTML.'
+url='https://github.com/PixxxeL/python-html-purifier.git'
+arch=('any')
+license=('GPL')
+depends=('python')
+makedepends=('git')
+provides=('python-html-purifier')
+
+source=("git+https://github.com/$author/$_gitname.git")
+
+md5sums=('SKIP')
+sha1sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf '0.r%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+ python setup.py install --root=$pkgdir
+}