summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO47
-rw-r--r--LICENSE17
-rw-r--r--PKGBUILD49
3 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a586b43f043
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+# Generated by mksrcinfo v8
+# Fri Dec 16 12:51:59 UTC 2016
+pkgbase = python-html5lib-git
+ pkgver = 0.999999.r4.g935783d
+ pkgrel = 1
+ url = https://github.com/html5lib
+ arch = any
+ license = MIT
+ checkdepends = python-six
+ checkdepends = python2-six
+ checkdepends = python2-pytest
+ checkdepends = python-pytest
+ checkdepends = python-lxml
+ checkdepends = python2-lxml
+ checkdepends = python-mock
+ checkdepends = python2-mock
+ makedepends = python2
+ makedepends = python
+ makedepends = unzip
+ makedepends = python-webencodings
+ makedepends = python2-webencodings
+ provides = python-html5lib
+ conflicts = python-html5lib
+ replaces = python-html5lib
+ source = python-html5lib-git::git+https://github.com/html5lib/html5lib-python.git#commit=935783d086498481fec1246a727d4fd01ec7017e
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 838c366f69b72c5df05c96dff79b35f2
+
+pkgname = python2-html5lib-git
+ pkgdesc = A Python2 HTML parser/tokenizer based on the WHATWG HTML5 spec
+ depends = python2
+ depends = python2-six
+ depends = python2-webencodings
+ provides = python2-html5lib
+ conflicts = python2-html5lib
+ replaces = python2-html5lib
+
+pkgname = python-html5lib-git
+ pkgdesc = A Python HTML parser/tokenizer based on the WHATWG HTML5 spec
+ depends = python
+ depends = python-six
+ depends = python-webencodings
+ provides = python-html5lib
+ conflicts = python-html5lib
+ replaces = python-html5lib
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..89de354795ec
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcb23de7cb84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: M0Rf30
+
+pkgbase=python-html5lib-git
+pkgname=('python2-html5lib-git' 'python-html5lib-git')
+pkgver=0.999999.r4.g935783d
+pkgrel=1
+arch=('any')
+url="https://github.com/html5lib"
+license=('MIT')
+makedepends=('python2' 'python' 'unzip' 'python-webencodings' 'python2-webencodings')
+checkdepends=('python-six' 'python2-six' 'python2-pytest' 'python-pytest' 'python-lxml' 'python2-lxml' 'python-mock' 'python2-mock')
+source=($pkgbase::git+https://github.com/html5lib/html5lib-python.git#commit=935783d086498481fec1246a727d4fd01ec7017e
+ LICENSE)
+provides=('python-html5lib')
+replaces=('python-html5lib')
+conflicts=('python-html5lib')
+package_python-html5lib-git() {
+pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec"
+depends=('python' 'python-six' 'python-webencodings')
+provides=('python-html5lib')
+replaces=('python-html5lib')
+conflicts=('python-html5lib')
+
+ cd ${srcdir}/${pkgbase}
+
+ python3 setup.py install --root=${pkgdir}
+ install -Dm755 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_python2-html5lib-git() {
+depends=('python2' 'python2-six' 'python2-webencodings')
+pkgdesc="A Python2 HTML parser/tokenizer based on the WHATWG HTML5 spec"
+provides=('python2-html5lib')
+replaces=('python2-html5lib')
+conflicts=('python2-html5lib')
+
+ cd ${srcdir}/${pkgbase}
+
+ python2 setup.py install --root=${pkgdir}
+ install -Dm755 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+pkgver() {
+ cd ${pkgbase}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+md5sums=('SKIP'
+ '838c366f69b72c5df05c96dff79b35f2')