summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 325626a4c0ca..352dc7451b3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = python-httpcore
- pkgdesc = A minimal HTTP client
+pkgbase = python-httpcore0.10
+ pkgdesc = A minimal HTTP client (version 0.10)
pkgver = 0.10.2
pkgrel = 1
url = https://github.com/encode/httpcore
@@ -9,14 +9,16 @@ pkgbase = python-httpcore
checkdepends = python-pytest-trio
checkdepends = python-trustme
checkdepends = uvicorn
- checkdepends = mitmproxy
+ checkdepends = mitmproxy<7
makedepends = python-setuptools
makedepends = python-h2
depends = python-h11
depends = python-sniffio
optdepends = python-h2: for HTTP/2 support
- source = python-httpcore-0.10.2.tar.gz::https://github.com/encode/httpcore/archive/0.10.2.tar.gz
+ provides = python-httpcore=0.10.2
+ conflicts = python-httpcore
+ source = python-httpcore0.10-0.10.2.tar.gz::https://github.com/encode/httpcore/archive/0.10.2.tar.gz
sha512sums = 714ae548d194f5eb71447d13669b32ae9b37deee5791e0e171e04c721eb99f21c55996cc06cf82f115d9e11d806c1d6c0b54fe61922bb419d90c94cd93e374ce
b2sums = ad5615b6a45dc5cd1a0128a6a6a48b0b29a4f56b753869c55018913a9047d712a028ed74a8fa2fcee36cc851f1c0f85a9f4ddf7c7aa1f5e3b28b09761c511aea
-pkgname = python-httpcore
+pkgname = python-httpcore0.10
diff --git a/PKGBUILD b/PKGBUILD
index 1364626b76a2..4dbb56a6186e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
_pkgname=httpcore
-pkgname=python-httpcore
+pkgname=python-httpcore0.10
pkgver=0.10.2
pkgrel=1
-pkgdesc="A minimal HTTP client"
+pkgdesc="A minimal HTTP client (version 0.10)"
arch=('any')
url="https://github.com/encode/${_pkgname}"
license=('BSD')
depends=('python-h11' 'python-sniffio')
optdepends=('python-h2: for HTTP/2 support')
makedepends=('python-setuptools' 'python-h2')
-checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trustme' 'uvicorn' 'mitmproxy')
+checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trustme' 'uvicorn' 'mitmproxy<7')
+provides=("python-httpcore=${pkgver}")
+conflicts=('python-httpcore')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha512sums=('714ae548d194f5eb71447d13669b32ae9b37deee5791e0e171e04c721eb99f21c55996cc06cf82f115d9e11d806c1d6c0b54fe61922bb419d90c94cd93e374ce')
b2sums=('ad5615b6a45dc5cd1a0128a6a6a48b0b29a4f56b753869c55018913a9047d712a028ed74a8fa2fcee36cc851f1c0f85a9f4ddf7c7aa1f5e3b28b09761c511aea')