summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1882efca1eb7..06be8f932b48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-ibis
pkgdesc = A pandas-like deferred expression system, with first class SQL support
- pkgver = 0.11.2
+ pkgver = 3.0.2
pkgrel = 1
url = https://github.com/ibis-project/ibis
arch = any
license = Apache
checkdepends = python-pytest
makedepends = python-setuptools
- depends = python
+ depends = python-multipledispatch
depends = python-numpy
depends = python-pandas
+ depends = python-pydantic
+ depends = python-regex
depends = python-toolz
- source = https://github.com/ibis-project/ibis/archive/v0.11.2.tar.gz
- sha256sums = 2b89d636403db05da6a2e0f0ca398db26112bda2fba5ef59a3e7d46e2c70747e
+ source = https://files.pythonhosted.org/packages/source/i/ibis-framework/ibis-framework-3.0.2.tar.gz
+ sha256sums = 5051b56d125ef0f64375f5dc98873d3238736dd09a4b7aa615c0b40368f362d4
pkgname = python-ibis
-
diff --git a/PKGBUILD b/PKGBUILD
index b2b579e33841..68a59785ca1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-ibis
-_pkgname=ibis
-pkgver=0.11.2
+_pkgname=ibis-framework
+pkgver=3.0.2
pkgrel=1
pkgdesc="A pandas-like deferred expression system, with first class SQL support"
arch=('any')
url="https://github.com/ibis-project/ibis"
license=('Apache')
-depends=('python' 'python-numpy' 'python-pandas' 'python-toolz')
+depends=('python-multipledispatch' 'python-numpy' 'python-pandas' 'python-pydantic' 'python-regex' 'python-toolz')
checkdepends=('python-pytest')
optdepends=()
makedepends=('python-setuptools')
-source=("https://github.com/ibis-project/ibis/archive/v$pkgver.tar.gz")
-sha256sums=('2b89d636403db05da6a2e0f0ca398db26112bda2fba5ef59a3e7d46e2c70747e')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('5051b56d125ef0f64375f5dc98873d3238736dd09a4b7aa615c0b40368f362d4')
+
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
#check(){
-# cd "$srcdir/$_pkgname-$pkgver/ibis"
-# py.test
+ #local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+
+ #cd "$_pkgname-$pkgver"
+ #python setup.py install --root=test_dir
+ #export PYTHONPATH="test_dir/$_site_packages:$PYTHONPATH"
+ #rm ibis/tests/test_version.py
+ #mv test_dir/$_site_packages/ibis{_framework,}-${pkgver}-py3.10.egg-info/
+ #pytest
#}
# vim:ts=2:sw=2:et: