summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1882efca1eb7..b46811f18993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ibis
pkgdesc = A pandas-like deferred expression system, with first class SQL support
- pkgver = 0.11.2
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/ibis-project/ibis
arch = any
@@ -8,11 +8,13 @@ pkgbase = python-ibis
checkdepends = python-pytest
makedepends = python-setuptools
depends = python
+ depends = python-multipledispatch
depends = python-numpy
depends = python-pandas
+ depends = python-regex
depends = python-toolz
- source = https://github.com/ibis-project/ibis/archive/v0.11.2.tar.gz
- sha256sums = 2b89d636403db05da6a2e0f0ca398db26112bda2fba5ef59a3e7d46e2c70747e
+ source = https://github.com/ibis-project/ibis/archive/v0.13.0.tar.gz
+ sha256sums = 3da1b51c72e074183abb08a2724a5b77f90e7328ab014de5ff7e699daf5c75f9
pkgname = python-ibis
diff --git a/PKGBUILD b/PKGBUILD
index b2b579e33841..2b6c8f9da04a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=python-ibis
_pkgname=ibis
-pkgver=0.11.2
+pkgver=0.13.0
pkgrel=1
pkgdesc="A pandas-like deferred expression system, with first class SQL support"
arch=('any')
url="https://github.com/ibis-project/ibis"
license=('Apache')
-depends=('python' 'python-numpy' 'python-pandas' 'python-toolz')
+depends=('python' 'python-multipledispatch' 'python-numpy' 'python-pandas' 'python-regex' 'python-toolz')
checkdepends=('python-pytest')
optdepends=()
makedepends=('python-setuptools')
source=("https://github.com/ibis-project/ibis/archive/v$pkgver.tar.gz")
-sha256sums=('2b89d636403db05da6a2e0f0ca398db26112bda2fba5ef59a3e7d46e2c70747e')
+sha256sums=('3da1b51c72e074183abb08a2724a5b77f90e7328ab014de5ff7e699daf5c75f9')
package(){
cd "$srcdir/$_pkgname-$pkgver"