summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab645a48e9f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-igl-git
+ pkgdesc = Python bindings for libigl
+ pkgver = 0.4.1.r54.ae3b42e
+ pkgrel = 1
+ url = https://github.com/libigl/libigl-python-bindings
+ arch = x86_64
+ license = GPL
+ license = MPL2
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = cmake>=3.2
+ depends = glibc
+ depends = gcc-libs
+ depends = python-numpy
+ provides = python-igl
+ conflicts = python-igl
+ source = python-igl::git+https://github.com/libigl/libigl-python-bindings.git
+ md5sums = SKIP
+
+pkgname = python-igl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6f0f8276a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jean Jouve <jean.jouve at protonmail dot com>
+
+pkgname=python-igl-git
+pkgver=0.4.1.r54.ae3b42e
+pkgrel=1
+pkgdesc="Python bindings for libigl"
+arch=('x86_64')
+url="https://github.com/libigl/libigl-python-bindings"
+license=('GPL' 'MPL2')
+depends=('glibc' 'gcc-libs' 'python-numpy')
+makedepends=('git' 'python-setuptools' 'cmake>=3.2')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('python-igl::git+https://github.com/libigl/libigl-python-bindings.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ #Using --tags because the tages in the repository are not annotated
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname%-git}"
+ python setup.py test
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}