summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f8852b3bc7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-imapclient
+ pkgdesc = An easy-to-use, Pythonic and complete IMAP client library with no dependencies outside the Python standard library
+ pkgver = 0.12
+ pkgrel = 1
+ url = http://imapclient.freshfoo.com/
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ depends = python
+ options = !emptydirs
+ source = http://freshfoo.com/projects/IMAPClient/IMAPClient-0.12.tar.gz
+ md5sums = bb7dc4cb2b4ab82ebc73e0f01cb60e1d
+
+pkgname = python-imapclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34ba288a46de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Carol Alexandru shapeshifter@archlinux.us
+pkgname=python-imapclient
+pkgver=0.12
+pkgrel=1
+pkgdesc="An easy-to-use, Pythonic and complete IMAP client library with no dependencies outside the Python standard library"
+arch=('any')
+url="http://imapclient.freshfoo.com/"
+license=('BSD')
+depends=('python')
+makedepends=('python-distribute')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+source=("http://freshfoo.com/projects/IMAPClient/IMAPClient-$pkgver.tar.gz")
+md5sums=('bb7dc4cb2b4ab82ebc73e0f01cb60e1d')
+
+package() {
+ cd "$srcdir/IMAPClient-$pkgver"
+ python setup.py install --root=$pkgdir/ --optimize=1
+}
+