summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e3d5eec314a..8fe07005dcd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-iptables
pkgdesc = Python bindings for iptables
- pkgver = 0.12.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/ldx/python-iptables
arch = x86_64
arch = i686
+ arch = aarch64
+ arch = armv7h
license = Apache
makedepends = python-setuptools
+ makedepends = gcc
depends = python
depends = iptables
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/p/python-iptables/python-iptables-0.12.0.tar.gz
- sha256sums = 9815fd5ba780fd14b5f8cf8a93e007c0e603019738813a806e37553cd72e4c33
+ source = https://github.com/ldx/python-iptables/archive/v1.0.1.tar.gz
+ sha256sums = 0ab4d2b1e4c268717dd2e7cb0f527dee06f39cdcdd763f1803a6f2618fe410ee
pkgname = python-iptables
-
diff --git a/PKGBUILD b/PKGBUILD
index d709ff5ccf9e..92f0663a5265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: la Fleur <lafleur at boum dot org>
# Contributor: Ivan Cai <caizixian@users.noreply.github.com>
-pkgname=python-iptables
-pkgver=1.0.0
+pkgname=python-iptables
+pkgver=1.0.1
pkgrel=1
pkgdesc='Python bindings for iptables'
-arch=('x86_64' 'i686' 'armv6h')
+arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url='https://github.com/ldx/python-iptables'
license=('Apache')
groups=()
depends=('python' 'iptables')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'gcc')
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
source=("https://github.com/ldx/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('f0193c73a7300b7ffd7a2b3dab2692b6358168b9162ab03271e9adff720c9503')
check() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -28,3 +27,5 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
+
+sha256sums=('0ab4d2b1e4c268717dd2e7cb0f527dee06f39cdcdd763f1803a6f2618fe410ee')