summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD51
3 files changed, 32 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab0ff0275525..2de23877ac98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-iptools
pkgdesc = Collection of utilities for dealing with IP addresses
pkgver = 0.7.0
- pkgrel = 1
- url = http://python-iptools.readthedocs.org/
+ pkgrel = 3
+ url = https://python-iptools.readthedocs.org/
arch = any
license = BSD
+ checkdepends = python-nose
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = LICENSE
- source = https://github.com/bd808/python-iptools/archive/v0.7.0.tar.gz
- sha256sums = c85e8d34884219ec4ac360f28983b015953ec34b1c6d91e6afbb8b421626ea9e
+ makedepends = python-sphinx
+ depends = python
+ source = python-iptools-0.7.0.tar.gz::https://github.com/bd808/python-iptools/archive/v0.7.0.tar.gz
sha256sums = 5ea59c0867e72d8243305ff1297fc5b2d8feaca650369a29985453ce4f39ca97
pkgname = python-iptools
- depends = python
-
-pkgname = python2-iptools
- depends = python2
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index deaf0fb4a27b..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-Copyright (c) 2008-2014, Bryan Davis and iptools contributors
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- a. Redistributions of source code must retain the above copyright notice,
- this list of conditions and the following disclaimer.
-
- b. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index adf73593d75f..3814d9074ca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: shieldwed <shieldwed [at] outlook [dot] com>
+# Maintainer:
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: shieldwed <shieldwed [at] outlook [dot] com>
-pkgbase=python-iptools
-pkgname=(python-iptools python2-iptools)
+pkgname=python-iptools
pkgver=0.7.0
-pkgrel=1
+pkgrel=3
pkgdesc="Collection of utilities for dealing with IP addresses"
-url="http://python-iptools.readthedocs.org/"
+url="https://python-iptools.readthedocs.org/"
license=('BSD')
arch=('any')
-makedepends=(
- 'python-setuptools'
- 'python2-setuptools'
- )
-source=(
- "LICENSE"
- "https://github.com/bd808/$pkgbase/archive/v$pkgver.tar.gz"
- )
-sha256sums=('c85e8d34884219ec4ac360f28983b015953ec34b1c6d91e6afbb8b421626ea9e'
- '5ea59c0867e72d8243305ff1297fc5b2d8feaca650369a29985453ce4f39ca97')
+depends=('python')
+makedepends=('python-setuptools' 'python-sphinx')
+checkdepends=('python-nose')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bd808/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('5ea59c0867e72d8243305ff1297fc5b2d8feaca650369a29985453ce4f39ca97')
-package_python-iptools() {
- depends=('python')
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "$srcdir/$pkgbase-$pkgver"
- python setup.py install "--root=$pkgdir" --optimize=1
+build() {
+ pushd "$pkgname-$pkgver"
+ python setup.py build
+ cd docs
+ make man BUILDDIR="$srcdir"
}
-package_python2-iptools() {
- depends=('python2')
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "$srcdir/$pkgbase-$pkgver"
- python2 setup.py install "--root=$pkgdir" --optimize=1
+check() {
+ pushd "$pkgname-$pkgver"
+ nosetests
+}
+
+package() {
+ install -Dm 644 man/iptools.1 -t "$pkgdir/usr/share/man/man1/"
+ cd "$pkgname-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}