summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD34
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1af7c3c9be3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-iptools
+ pkgdesc = Collection of utilities for dealing with IP addresses
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = http://python-iptools.readthedocs.org/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = LICENSE
+ source = https://github.com/bd808/python-iptools/archive/v0.6.1.tar.gz
+ sha256sums = c85e8d34884219ec4ac360f28983b015953ec34b1c6d91e6afbb8b421626ea9e
+ sha256sums = 77513ec4982a807ef636b1b847d3f6ebe69e2e56faf6cb5d425106be9a24d02c
+
+pkgname = python-iptools
+ depends = python
+
+pkgname = python2-iptools
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a52611a641d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..deaf0fb4a27b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 2008-2014, Bryan Davis and iptools contributors
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ a. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ b. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2be8bc6f542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: shieldwed <shieldwed [at] outlook [dot] com>
+
+pkgbase=python-iptools
+pkgname=(python-iptools python2-iptools)
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Collection of utilities for dealing with IP addresses"
+url="http://python-iptools.readthedocs.org/"
+license=('BSD')
+arch=('any')
+makedepends=(
+ 'python-setuptools'
+ 'python2-setuptools'
+ )
+source=(
+ "LICENSE"
+ "https://github.com/bd808/$pkgbase/archive/v$pkgver.tar.gz"
+ )
+sha256sums=('c85e8d34884219ec4ac360f28983b015953ec34b1c6d91e6afbb8b421626ea9e'
+ '77513ec4982a807ef636b1b847d3f6ebe69e2e56faf6cb5d425106be9a24d02c')
+
+package_python-iptools() {
+ depends=('python')
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/$pkgbase-$pkgver"
+ python setup.py install "--root=$pkgdir" --optimize=1
+}
+
+package_python2-iptools() {
+ depends=('python2')
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/$pkgbase-$pkgver"
+ python2 setup.py install "--root=$pkgdir" --optimize=1
+}