summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--scikit-build.patch12
3 files changed, 12 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cccf83f840a4..ed53efafbcfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = python-jarowinkler
pkgdesc = A library for fast approximate string matching using Jaro and Jaro-Winkler similarity
- pkgver = 1.2.3
- pkgrel = 2
+ pkgver = 2.0.1
+ pkgrel = 1
url = https://github.com/maxbachmann/JaroWinkler
arch = x86_64
license = MIT
checkdepends = python-hypothesis
checkdepends = python-pytest
+ makedepends = python-pip
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-scikit-build
- makedepends = python-rapidfuzz-capi
makedepends = ninja
depends = python
- source = https://files.pythonhosted.org/packages/source/j/jarowinkler/jarowinkler-1.2.3.tar.gz
- source = scikit-build.patch
- sha256sums = af28ea284cfbd1b21b29ff94b759f20e94e4f7c06f424b0b4702e701c2a21668
- sha256sums = d74321eed1e4b41ad8dcd81e2412ac5b84602fce147a212ddad32a9ebab3288e
+ depends = python-rapidfuzz
+ source = https://files.pythonhosted.org/packages/source/j/jarowinkler/jarowinkler-2.0.1.tar.gz
+ sha256sums = 7640c79f8d2d5e9eed6691cb49e3018a23b2319daad9a2178df253368b5432b7
pkgname = python-jarowinkler
diff --git a/PKGBUILD b/PKGBUILD
index e1cd5ec1dc7c..f0cfe7181821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,17 @@
_name=jarowinkler
pkgname=python-$_name
-pkgver=1.2.3
-pkgrel=2
+pkgver=2.0.1
+pkgrel=1
pkgdesc='A library for fast approximate string matching using Jaro and Jaro-Winkler similarity'
arch=(x86_64)
url='https://github.com/maxbachmann/JaroWinkler'
license=(MIT)
-depends=(python)
-#makedepends=(jarowinkler-cpp python-rapidfuzz-capi python-scikit-build)
-makedepends=(python-build python-installer python-setuptools python-scikit-build python-rapidfuzz-capi ninja)
+depends=(python python-rapidfuzz)
+makedepends=(python-pip python-build python-installer python-setuptools python-scikit-build ninja)
checkdepends=(python-hypothesis python-pytest)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "scikit-build.patch")
-sha256sums=('af28ea284cfbd1b21b29ff94b759f20e94e4f7c06f424b0b4702e701c2a21668'
- 'd74321eed1e4b41ad8dcd81e2412ac5b84602fce147a212ddad32a9ebab3288e')
-
-prepare() {
- patch --directory="${_name}-${pkgver}" --forward --strip=1 --input="${srcdir}/scikit-build.patch"
-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('7640c79f8d2d5e9eed6691cb49e3018a23b2319daad9a2178df253368b5432b7')
build() {
cd $_name-$pkgver
diff --git a/scikit-build.patch b/scikit-build.patch
deleted file mode 100644
index ba5a14c269f2..000000000000
--- a/scikit-build.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text jarowinkler-1.2.3-orig/pyproject.toml jarowinkler-1.2.3/pyproject.toml
---- jarowinkler-1.2.3-orig/pyproject.toml 2022-09-27 15:18:32.000000000 -0500
-+++ jarowinkler-1.2.3/pyproject.toml 2023-05-25 13:31:59.504400391 -0500
-@@ -1,7 +1,7 @@
- [build-system]
- requires = [
- "setuptools>=42",
-- "scikit-build==0.15.0",
-+ "scikit-build>=0.15.0",
- "rapidfuzz_capi==1.0.5"
- ]
- build-backend = "backend"