summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ca2afa803bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-json-ref-dict
+ pkgdesc = Python dict-like object which abstracts resolution of JSONSchema references
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/jacksmith15/json-ref-dict
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-jsonpointer
+ source = https://github.com/jacksmith15/json-ref-dict/archive/refs/tags/0.7.0.tar.gz
+ sha256sums = ebd4f6ba724c49abe8d14a61de49e408a48cc5aa5a89e756ee0ef4070ec3a375
+
+pkgname = python-json-ref-dict
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5dbe4b3462a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
+pkgname=python-json-ref-dict
+_name=${pkgname#python-}
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Python dict-like object which abstracts resolution of JSONSchema references"
+arch=(any)
+url="https://github.com/jacksmith15/json-ref-dict"
+license=('MIT')
+depends=(python python-jsonpointer)
+source=("https://github.com/jacksmith15/${_name}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('ebd4f6ba724c49abe8d14a61de49e408a48cc5aa5a89e756ee0ef4070ec3a375')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}