summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34dfc88a39a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-jupyter-http-over-ws
+ pkgdesc = Jupyter support for HTTP-over-ws
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/googlecolab/jupyter_http_over_ws
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = jupyter-notebook
+ depends = python-six
+ depends = python-tornado
+ source = https://pypi.org/packages/source/j/jupyter_http_over_ws/jupyter_http_over_ws-0.0.6.tar.gz
+ sha256sums = 3c721e2514ef8c3e19c2cb8b0c0ef88f0e08448fd79bc1ef4a809a897c47b02f
+
+pkgname = python-jupyter-http-over-ws
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66685909344b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: hexchain <i at hexchain dot org>
+
+_pypiname=jupyter_http_over_ws
+pkgname=python-jupyter-http-over-ws
+pkgdesc="Jupyter support for HTTP-over-ws"
+url="https://github.com/googlecolab/jupyter_http_over_ws"
+license=('Apache')
+arch=('any')
+pkgver=0.0.6
+pkgrel=1
+depends=('jupyter-notebook' 'python-six' 'python-tornado')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_pypiname:0:1}/$_pypiname/$_pypiname-$pkgver.tar.gz")
+sha256sums=('3c721e2514ef8c3e19c2cb8b0c0ef88f0e08448fd79bc1ef4a809a897c47b02f')
+
+build() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py install --optimize=1 --root="$pkgdir/" --prefix=/usr --skip-build
+}