summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d8f54d74c12..3de5a9bef8af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-keepassxc-browser
pkgdesc = Access the KeepassXC Browser API from python
- pkgver = 0.1.4
+ pkgver = 0.1.8
pkgrel = 1
url = https://github.com/hrehfeld/python-keepassxc-browser
arch = any
- license = AGPL3
+ license = AGPL-3.0
makedepends = python
makedepends = python-pip
- depends = python-libnacl
+ depends = python-pysodium
depends = python
pkgname = python-keepassxc-browser
-
diff --git a/PKGBUILD b/PKGBUILD
index a713d05bbc42..4e0c5a67c754 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Python package author: Hauke Rehfeld <pypi.org@haukerehfeld.de>
# Maintainer: Hauke Rehfeld <aur.archlinux.org@haukerehfeld.de>
pkgname=python-keepassxc-browser
-pkgver=0.1.4
+pkgver=0.1.8
pkgrel=1
pkgdesc="Access the KeepassXC Browser API from python"
arch=(any)
url="https://github.com/hrehfeld/python-keepassxc-browser"
-license=('AGPL3')
-depends=("python-libnacl" "python")
+license=('AGPL-3.0')
+depends=("python-pysodium" "python")
makedepends=("python" "python-pip")
build() {
- pip install --upgrade --no-deps --target="keepassxc-browser" keepassxc-browser==${pkgver}
+ pip install --no-deps --target="keepassxc-browser" keepassxc-browser==${pkgver}
}
package() {
sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")