summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 119fc5feb225..3329c1004cb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-kymatio
pkgdesc = Wavelet scattering in Python
- pkgver = 0.2.0
- pkgrel = 2
- url = http://spams-devel.gforge.inria.fr/
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://www.kymat.io/
arch = any
license = GPLv3
makedepends = python-setuptools
@@ -12,8 +12,7 @@ pkgbase = python-kymatio
depends = python-appdirs
depends = python-configparser
depends = python-packaging
- source = https://files.pythonhosted.org/packages/source/k/kymatio/kymatio-0.2.0.tar.gz
- sha256sums = 32fbb2b5c1ceeeadc30029d6d9d4590a35052cc7c685cf2bb049690708bd3dfb
+ source = git+https://github.com/kymatio/kymatio#tag=0.3.0
+ sha256sums = SKIP
pkgname = python-kymatio
-
diff --git a/PKGBUILD b/PKGBUILD
index 99adcbc72573..ff674f01f802 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
# Maintainer: Paul Irofti <paul@irofti.net>
_name=kymatio
pkgname="python-$_name"
-pkgver=0.2.0
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc="Wavelet scattering in Python"
arch=('any')
-url="http://spams-devel.gforge.inria.fr/"
+url="https://www.kymat.io/"
license=('GPLv3')
depends=('python' 'python-numpy' 'python-scipy' 'python-appdirs'
'python-configparser' 'python-packaging')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('32fbb2b5c1ceeeadc30029d6d9d4590a35052cc7c685cf2bb049690708bd3dfb')
-
-prepare() {
- cd "$srcdir/$_name-$pkgver"
- sed -i s,requirements.txt,${_name}.egg-info\/requires.txt, setup.py
-}
+source=("git+https://github.com/${_name}/${_name}#tag=${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$srcdir/$_name"
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$srcdir/$_name"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}