summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e689d59a1132..51c7e621b011 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-lifelines
pkgdesc = Survival analysis in Python
- pkgver = 0.22.7
+ pkgver = 0.28.0
pkgrel = 1
url = https://github.com/CamDavidsonPilon/lifelines
arch = any
license = MIT
makedepends = python-setuptools
+ depends = ipython
depends = python-autograd-gamma
depends = python-matplotlib
depends = python-pandas
+ depends = python-scikit-learn
+ depends = python-formulaic
options = !emptydirs
- source = lifelines-0.22.7.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/v0.22.7.tar.gz
- sha256sums = 77351e10bee82776fd0845e0ae1d8c9f4c1485c69762946e8700f5173b65f83c
+ source = python-lifelines-0.28.0.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v0.28.0.tar.gz
+ sha256sums = 18831a3c8e4e101878d53cf67c83afecb1df24bc18facebb2aa2cbc1a8bf5368
pkgname = python-lifelines
-
diff --git a/PKGBUILD b/PKGBUILD
index 1c8015f1657a..254647cb65cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=lifelines
pkgname=python-lifelines
-pkgver=0.22.7
+pkgver=0.28.0
pkgrel=1
pkgdesc="Survival analysis in Python"
url="https://github.com/CamDavidsonPilon/lifelines"
arch=('any')
license=('MIT')
-depends=('python-autograd-gamma' 'python-matplotlib' 'python-pandas')
+depends=('ipython' 'python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-scikit-learn' 'python-formulaic')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/v${pkgver}.tar.gz")
-sha256sums=('77351e10bee82776fd0845e0ae1d8c9f4c1485c69762946e8700f5173b65f83c')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('18831a3c8e4e101878d53cf67c83afecb1df24bc18facebb2aa2cbc1a8bf5368')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -23,9 +23,4 @@ package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # Move Files
- mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
- _ver=$(python -c "import platform; print(platform.python_version())")
- mv ${pkgdir}/usr/lib/python${_ver%.*}/site-packages/{LICENSE,README.md,MANIFEST.in} ${pkgdir}/usr/share/doc/${pkgname}
}