summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD2
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea2ead022467..f1694f991f15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,10 @@ pkgbase = python-lineprofiler
license = BSD
checkdepends = python-pytest
checkdepends = python-ubelt
- makedepends = cython
+ makedepends = cython3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-setuptools
depends = ipython
source = line_profiler-4.0.2.tar.gz::https://github.com/pyutils/line_profiler/archive/v4.0.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4e2d262389ac..a961d3ed00bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://pypi.python.org/pypi/line_profiler"
arch=('x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
-makedepends=('cython')
+makedepends=('cython3' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest' 'python-ubelt')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/v$pkgver.tar.gz")