summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48820e4b88d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-lineprofiler
+ pkgdesc = Line-by-line profiler
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/line_profiler
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cython
+ depends = python-setuptools
+ source = http://pypi.python.org/packages/source/l/line_profiler/line_profiler-1.0.tar.gz
+ md5sums = 2f8352acfedf83f701a564583db5e14d
+
+pkgname = python-lineprofiler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c66104ddcd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rich Li <rich at dranek com>
+# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+# Contributor: Sebastien Binet <binet@lblbox>
+pkgname=python-lineprofiler
+pkgver=1.0
+pkgrel=1
+pkgdesc="Line-by-line profiler"
+url="http://pypi.python.org/pypi/line_profiler"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('python-setuptools')
+makedepends=('cython')
+source=(http://pypi.python.org/packages/source/l/line_profiler/line_profiler-$pkgver.tar.gz)
+md5sums=('2f8352acfedf83f701a564583db5e14d')
+
+build() {
+ cd "${srcdir}/line_profiler-${pkgver}"
+ python setup.py build
+}
+
+# # Doesn't work
+# check() {
+# cd "${srcdir}/line_profiler-${pkgver}"
+# python -m unittest discover -v tests
+# }
+
+package() {
+ cd "${srcdir}/line_profiler-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE{,_Python}.txt "${pkgdir}/usr/share/licenses/${pkgname}"
+}