summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe3058b44285
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = litedram-git
+ pkgdesc = A small footprint and configurable DRAM core
+ pkgver = 181
+ pkgrel = 1
+ url = https://github.com/enjoy-digital/litedram
+ arch = any
+ license = MIT
+ depends = python
+ depends = migen
+ depends = litex
+ provides = litedram
+ options = !emptydirs
+ source = git+https://github.com/enjoy-digital/litedram
+ sha256sums = SKIP
+
+pkgname = litedram-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c01e58765bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Caleb Jamison <cbjamo@gmail.com>
+pkgname=litedram-git
+pkgver=181
+pkgrel=1
+pkgdesc="A small footprint and configurable DRAM core"
+arch=(any)
+url="https://github.com/enjoy-digital/litedram"
+license=('MIT')
+groups=()
+depends=('python' 'migen' 'litex')
+provides=('litedram')
+options=(!emptydirs)
+install=
+source=("git+https://github.com/enjoy-digital/litedram")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%%-git}"
+ rm -rf test/__init__.py
+}
+
+build() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}
+