summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9717b4f64eb..1f1c325c93eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mappy
pkgdesc = Python interface to minimap2, a fast and accurate C program to align genomic and transcribe nucleotide sequences
- pkgver = 2.24
+ pkgver = 2.25
pkgrel = 2
url = https://github.com/lh3/minimap2
arch = x86_64
@@ -8,12 +8,11 @@ pkgbase = python-mappy
makedepends = python-setuptools
makedepends = cython
makedepends = zlib
+ makedepends = python-wheel
depends = python
depends = minimap2
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/m/mappy/mappy-2.24.tar.gz
- source = https://github.com/lh3/minimap2/blob/1d3c3eef03216fde72f5e1a3850941b0193216d9/LICENSE.txt
- sha256sums = 35a2fb73ef14173283d5abb31e7a318429e0330c3be95851df38dd83d4ff9af9
- sha256sums = 8124fce0862f865aa6ec01d00dfaffcd7a350627799b63224485b1f04ea3d811
+ source = https://github.com/lh3/minimap2/archive/refs/tags/v2.25.tar.gz
+ sha256sums = 9742ff0be01e51ea7d65f70c01d1344eee6f0d7b135359e0c00aec30fb74ac38
pkgname = python-mappy
diff --git a/PKGBUILD b/PKGBUILD
index 0bcd9e79fb67..266101ac3ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: bipin kumar <bipin@ccmb.res.in>
+# Maintainer: Bipin Kumar <kbipinkumar@pm.me>
pkgname=python-mappy
-_module=${pkgname#python-}
-pkgver=2.24
+_module=minimap2
+pkgver=2.25
pkgrel=2
pkgdesc="Python interface to minimap2, a fast and accurate C program to align genomic and transcribe nucleotide sequences"
arch=('x86_64')
@@ -16,17 +16,17 @@ makedepends=(
'python-setuptools'
'cython'
'zlib'
+ 'python-wheel'
)
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
- "https://github.com/lh3/minimap2/blob/1d3c3eef03216fde72f5e1a3850941b0193216d9/LICENSE.txt")
-sha256sums=('35a2fb73ef14173283d5abb31e7a318429e0330c3be95851df38dd83d4ff9af9'
- '8124fce0862f865aa6ec01d00dfaffcd7a350627799b63224485b1f04ea3d811')
+source=("https://github.com/lh3/minimap2/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('9742ff0be01e51ea7d65f70c01d1344eee6f0d7b135359e0c00aec30fb74ac38')
prepare() {
- cp LICENSE.txt "$_module-$pkgver"
-}
+ cd "$_module-$pkgver"
+ sed -i 's|CFLAGS= -g -Wall -O2 -Wc++-compat #-Wextra|CFLAGS= -g -Wall -O2 -Wc++-compat -fPIC #-Wextra|g' Makefile
+ }
build() {
cd "$_module-$pkgver"
@@ -36,5 +36,5 @@ build() {
package() {
cd "$_module-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "LICENSE.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
}