summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d99b21cb28c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-matplotlib2tikz-git
+ pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
+ pkgver = 0.6.12
+ pkgrel = 1
+ url = https://github.com/nschloe/matplotlib2tikz
+ arch = any
+ license = MIT
+ makedepends = python
+ depends = python
+ depends = python-numpy
+ depends = python-matplotlib>=1.4.0
+ depends = python-pillow
+ provides = python-matplotlib2tikz
+ conflicts = python-matplotlib2tikz
+ source = git+https://github.com/nschloe/matplotlib2tikz.git
+ md5sums = SKIP
+
+pkgname = python-matplotlib2tikz-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e506f1e28f77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: sasvari <sasvari@fastmail.com>
+pkgname=python-matplotlib2tikz-git
+pkgver=0.6.12
+pkgrel=1
+pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
+url="https://github.com/nschloe/matplotlib2tikz"
+depends=('python' 'python-numpy' 'python-matplotlib>=1.4.0' 'python-pillow')
+makedepends=('python')
+provides=('python-matplotlib2tikz')
+conflicts=('python-matplotlib2tikz')
+license=('MIT')
+arch=('any')
+source=("git+https://github.com/nschloe/matplotlib2tikz.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/matplotlib2tikz"
+ python setup.py build
+}
+
+pkgver() {
+ cd "$srcdir/matplotlib2tikz"
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-/./'
+}
+
+#package() {
+# cd "${srcdir}/matplotlib2tikz-${pkgver}"
+# python2 setup.py install --root="${pkgdir}" --optimize=1
+# install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+package() {
+ cd "$srcdir/matplotlib2tikz"
+ python setup.py install --root="$pkgdir/" --prefix="/usr"
+}