summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c61cf683727b..903868fa6ef0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,15 +2,16 @@ pkgbase = python-mcipc-git
pkgdesc = Python 3 library and scripts for the RCON and Query protocol
pkgver = r142.30b3b0b
pkgrel = 1
- url = https://gitlab.com/coNQP/mcipc
+ url = https://github.com/coNQP/mcipc
arch = any
license = GPLv3
makedepends = git
makedepends = python
depends = python
depends = python-docopt
- depends = python-pyzmq
- source = mcipc::git+https://gitlab.com/coNQP/mcipc.git
+ provides = mcipc-git
+ replaces = mcipc-git
+ source = mcipc::git+https://github.com/coNQP/mcipc.git
md5sums = SKIP
pkgname = python-mcipc-git
diff --git a/PKGBUILD b/PKGBUILD
index 89d1a2a178e9..88d174b800a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,12 @@ pkgver=r142.30b3b0b
pkgrel=1
pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
arch=('any')
-url="https://gitlab.com/coNQP/${_pkgbase}"
+url="https://github.com/coNQP/${_pkgbase}"
license=('GPLv3')
-depends=('python' 'python-docopt' 'python-pyzmq')
+depends=('python' 'python-docopt')
makedepends=('git' 'python')
+provides=('mcipc-git')
+replaces=('mcipc-git')
source=("${_pkgbase}::git+${url}.git")
md5sums=('SKIP')
pkgdir='pkg'
@@ -17,7 +19,7 @@ srcdir='src'
pkgver() {
- cd "${_pkgbase}" || exit 1
+ cd "${_pkgbase}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}