summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dc2c81cee57..968c341bf18f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 10 09:33:28 UTC 2017
+# Fri Dec 15 18:53:51 UTC 2017
pkgbase = python-mechanicalsoup
pkgdesc = A Python library for automating interaction with websites
pkgver = 0.9.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hickford/MechanicalSoup
arch = any
license = MIT
@@ -17,10 +17,12 @@ pkgname = python-mechanicalsoup
depends = python-beautifulsoup4
depends = python-requests
depends = python-six
+ depends = python-lxml
pkgname = python2-mechanicalsoup
depends = python2
depends = python2-beautifulsoup4
depends = python2-requests
depends = python2-six
+ depends = python2-lxml
diff --git a/PKGBUILD b/PKGBUILD
index 1f60998a47fa..02441fec8074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=python-mechanicalsoup
pkgname=(python-mechanicalsoup python2-mechanicalsoup)
pkgver=0.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="A Python library for automating interaction with websites"
arch=('any')
url="https://github.com/hickford/MechanicalSoup"
@@ -20,14 +20,14 @@ check() {
}
package_python2-mechanicalsoup() {
- depends=('python2' 'python2-beautifulsoup4' 'python2-requests' 'python2-six')
+ depends=('python2' 'python2-beautifulsoup4' 'python2-requests' 'python2-six' 'python2-lxml')
cd $srcdir/MechanicalSoup-$pkgver
python2 setup.py install --root="$pkgdir/" --optimize=1
}
package_python-mechanicalsoup() {
- depends=('python' 'python-beautifulsoup4' 'python-requests' 'python-six')
+ depends=('python' 'python-beautifulsoup4' 'python-requests' 'python-six' 'python-lxml')
cd $srcdir/MechanicalSoup-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1