summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b53632556b4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-misaka
+ pkgdesc = The Python binding for Sundown, a markdown parsing library.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://misaka.61924.nl/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python
+ conflicts = python-misaka-v1
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/m/misaka/misaka-2.0.0.tar.gz
+ sha256sums = 336ef1381ab840046b7da9f95c4c28af17e636aed8dcfcf1efe972db05f73604
+
+pkgname = python-misaka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df44cafbc1a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor Häggqvist <aur a snilius d com>
+# https://github.com/victorhaggqvist/archlinux-pkgbuilds
+pkgname=python-misaka
+_pkgname=misaka
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="The Python binding for Sundown, a markdown parsing library."
+arch=('i686' 'x86_64')
+url="http://misaka.61924.nl/"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+conflicts=('python-misaka-v1')
+source=("https://pypi.python.org/packages/source/m/misaka/misaka-${pkgver}.tar.gz")
+sha256sums=('336ef1381ab840046b7da9f95c4c28af17e636aed8dcfcf1efe972db05f73604')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: