summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96341d60dbb7..24a9c2e8653e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-monty
pkgdesc = Monty is the missing complement to Python
- pkgver = 2023.4.10
+ pkgver = 2023.5.8
pkgrel = 1
url = https://github.com/materialsvirtuallab/monty
arch = x86_64
@@ -11,9 +11,12 @@ pkgbase = python-monty
checkdepends = python-pydantic
checkdepends = python-ruamel-yaml
checkdepends = python-tqdm
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- source = monty-2023.4.10.tar.gz::https://github.com/materialsvirtuallab/monty/archive/v2023.4.10.tar.gz
- sha512sums = 530eaf9b73cd92f93e0ac7d04bfd52dae9755badb0eda7bef4021751c89ad1d44b8019fa3e4d076c2cfc7175e9a926df72204082d19f7eeeba5e62db80623a80
+ source = monty-2023.5.8.tar.gz::https://github.com/materialsvirtuallab/monty/archive/v2023.5.8.tar.gz
+ sha512sums = 07c62bbafff0f13434594ea70efceb4cbc3803d4a1ef4feac48c2a057663e459f15421cfcce9c8e4bde10adaec8e02faae033611972dbfd3c9141de371ddd453
pkgname = python-monty
diff --git a/PKGBUILD b/PKGBUILD
index 9b177b222a07..004f5dcca419 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,31 @@
_base=monty
pkgname=python-${_base}
pkgdesc="Monty is the missing complement to Python"
-pkgver=2023.4.10
+pkgver=2023.5.8
pkgrel=1
arch=(x86_64)
url="https://github.com/materialsvirtuallab/${_base}"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest python-bson python-pandas python-pydantic python-ruamel-yaml python-tqdm)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('530eaf9b73cd92f93e0ac7d04bfd52dae9755badb0eda7bef4021751c89ad1d44b8019fa3e4d076c2cfc7175e9a926df72204082d19f7eeeba5e62db80623a80')
+sha512sums=('07c62bbafff0f13434594ea70efceb4cbc3803d4a1ef4feac48c2a057663e459f15421cfcce9c8e4bde10adaec8e02faae033611972dbfd3c9141de371ddd453')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
cd ${_base}-${pkgver}
- python -m pytest tests -k 'not reverse_readfile_gz and not Path_objects and not zopen and not zpath'
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest tests -k 'not reverse_readfile_gz and not Path_objects and not zopen and not zpath'
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
}