summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 263fe592a551..79ba9e1c014a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-monty
pkgdesc = Monty is the missing complement to Python
- pkgver = 2022.9.8
+ pkgver = 2022.9.9
pkgrel = 1
url = https://github.com/materialsvirtuallab/monty
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = python-monty
checkdepends = python-tqdm
makedepends = python-setuptools
depends = python
- source = monty-2022.9.8.tar.gz::https://github.com/materialsvirtuallab/monty/archive/v2022.9.8.tar.gz
- sha512sums = 3ea10ed3147571d2dc4bbe6a8cc246613986d89144fa4367d28fcdff4052d0021b229e32c9d6f5635251c076f456dc71509c4b607edc6397246ab9213803d0c8
+ source = monty-2022.9.9.tar.gz::https://github.com/materialsvirtuallab/monty/archive/v2022.9.9.tar.gz
+ sha512sums = 987cce5aacbdaa514a61b766c361775a054b8651e9b3dc2db23b0fe8117574c7eb539228a1b2e2b22e61e6de8348c805f336e8c4f6d4853de81d352273b16eb9
pkgname = python-monty
diff --git a/PKGBUILD b/PKGBUILD
index 3f0ead53f9dc..844d81ed1825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-
_base=monty
pkgname=python-${_base}
pkgdesc="Monty is the missing complement to Python"
-pkgver=2022.9.8
+pkgver=2022.9.9
pkgrel=1
arch=(x86_64)
url="https://github.com/materialsvirtuallab/${_base}"
@@ -12,7 +11,7 @@ depends=(python)
makedepends=(python-setuptools)
checkdepends=(python-pytest python-bson python-pandas python-pydantic python-ruamel-yaml python-tqdm)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('3ea10ed3147571d2dc4bbe6a8cc246613986d89144fa4367d28fcdff4052d0021b229e32c9d6f5635251c076f456dc71509c4b607edc6397246ab9213803d0c8')
+sha512sums=('987cce5aacbdaa514a61b766c361775a054b8651e9b3dc2db23b0fe8117574c7eb539228a1b2e2b22e61e6de8348c805f336e8c4f6d4853de81d352273b16eb9')
build() {
cd ${_base}-${pkgver}
@@ -21,7 +20,7 @@ build() {
check() {
cd ${_base}-${pkgver}
- python -m pytest tests
+ python -m pytest tests -k 'not io and not zpath'
}
package() {